FAQ: [ ERROR ] This client and the Conductor are incompatible after updating Client Tools

If you see this message after updating the Fugue Client Tools and running CLI commands: 

[ ERROR ] This client and the Conductor are incompatible...

Consider the following steps:

Resolution:

This is likely because the upgrade process picked the wrong AMI id. Browse to download.fugue.co to review the AMI ids of the current conductors. Confirm in your fugue.yaml file that the AMI id there matches the current public AMI for your conductor.

If it does not, manually edit the fugue.yaml to have the correct conductor.

Run a fugue upgrade command. Once the upgrade is finished, attempt to run fugue commands from the CLI.